Instalar PyDev en Eclipse para Os X 10.10 Yosemite

por miércoles, agosto 5, 2015 0 No tags Permalink 0

El primer paso consiste en descargar Eclipse Classic. Se elige la versión Classic por ser la más limpia y adecuada para instalar posteriormente los plugins necesario para el lenguaje de programación deseado, en nuestro caso Python. A la hora de escribir este artículo, la última versión estable es la Eclipse Classic 4.4.2 Juno.

Una vez descargado Eclipse procedemos a su instalación. Eclipse se habrá guardado por defecto la carpeta Descargas. Al activar el fichero descargado, todo el paquete se guardará en una carpeta llamada Eclipse. Como sugerencia, pude moverse toda la carpeta de Descargas a Aplicaciones. Abriendo la carpeta encontraremos el ejecutable Eclipse.app que abriremos para completar la instalación. Durante esta se nos preguntará por la ubicación de la carpeta  donde se guardaran los archivos creados mediante Eclipse. Podemos ubicar dicha carpeta (workspace) o modificar su nombre si lo deseamos.

Una vez se ha realizado la configuración básica de Eclipse, pasamos a instalar PyDev. Para ello vamos a Help/Install New Software/ y arriba a la derecha encontramos la opción Add. Hacemos click y se abre una ventana donde se deben rellenar dos campos:

  • Name: PyDev.
  • Location: http://pydev.org/updates

Aparece una ventana con dos opciones. Señalamos solamente la primera (PyDev) y hacemos click en Next para continuar la instalación hasta finalizarla. De este modo ya tenemos instalado PyDev.

Si todo ha funcionado correctamente, en Eclipse/Preferencias veremos aparecer PyDev en el menú vertical a la izquierda de la ventana emergente. Si no aparece, tenemos un problema con la versión de Java instalada. PyDev necesita Java 7, ya sea el JRE o el JDK.

Para ver la versión de Java que estamos utilizando vamos a Terminal y ejecutamos

$ java -version

Si aparece

> java -version
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

nos está indicando que trabajamos con la versión 6 que es la que viene por defecto en OS X 10.10 Yosemite.

En lugar de instalar el JRE, es más adecuado descargar e instalar el JDKen la versión 7 o superior. Actualmente la última versión es Java 8 que se puede descargar desde la página de Oracle. Elegimos la versión para Mac OS X de 64 bits: jdk-8u51-macosx-x64.dmg

Una vez descargada e instalada, veremos que se ha guardado en la siguiente ruta:

/Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home/bin/java

En Terminal veremos ahora las diferentes versiones instaladas:

/usr/libexec/java_home --verbose

con el siguiente resultado:

Matching Java Virtual Machines (3):
1.8.0_51, x86_64: "Java SE 8" /Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home
1.6.0_65-b14-466.1, x86_64: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
1.6.0_65-b14-466.1, i386: "Java SE 6" /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
/Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home

A continuación modificamos el archivo eclipse.ini para determinar la versión de Java que Elipse debe utilizar. Podemos encontrar el archivo eclipse.ini mediante ctrl-click  en el archivo de eclipse ejecutable Eclipse.app y seleccionando  Mostrar el contenido del paquete y navegando hasta Content/MacOS/. Abrimos el archivo con TextEdit y seguimos las instrucciones que nos indica Elipse para modificar el archivo. Concretamente, deben incluirse las siguientes dos líneas justo debajo de openFile:

openFile
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home/bin/java

El archivo tendrá finalmente el siguiente código:

-startup
../../../plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20120913-144807
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home/bin/java
-vmargs
-Xms40m
-Xmx512m
-Xdock:icon=../Resources/Eclipse.icns
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts

El último paso es reiniciar Eclipse. Una vez activo de nuevo, podemos dirigirnos de nuevo a Eclipse/Preferencias y finalmente encontraremos que PyDev se encuentra dentro de los lenguajes con los que podemos trabajar.

Comments are closed.